Prova: FCC – 2014 – TRT – 16ª REGIÃO (MA) – Analista Judiciário – Contabilidade

Luiza trabalha no Tribunal Regional do Trabalho da 16º Região do estado do Maranhão e recebeu uma planilha criada no Microsoft Excel 2010 em português, com apenas os nomes e os cargos dos magistrados que compõem o Tribunal, dados também presentes no site da instituição. A tarefa de Luiza é, a partir desta planilha, criar mais 2 colunas, uma com o primeiro nome dos magistrados e a outra com seu último sobrenome.

questao fcc trt ma

Para exibir o primeiro nome dos magistrados, Luiza digitou na célula C2 uma fórmula que obteve e exibiu apenas a primeira parte do nome contido na célula A2, neste caso, “Luiz”. Em seguida Luiza arrastou a fórmula para as células abaixo, obtendo o primeiro nome de todos os demais membros do Tribunal. A fórmula correta digitada por Luiza na célula C2 foi
a) =SEERRO(DIREITA(A2;PROCURAR(“-“;A2)-1);A2)
b) =PROCURAR(ESQUERDA(A2,1);A2)
c) =SEERRO(ESQUERDA(A2;PROCURAR(” “;A2)-1);A2)
d) =SEERRO(LEFT(A2;PROCURAR(A2)-1);A2)
e) =SEERRO(ESQUERDA(A2;PROCURAR(” “;A2)+1);A2)

Inicialmente, vamos identificar as funções envolvidas:

PROCURAR – localiza um texto dentro de uma sequência de caracteres e retorna a sua posição, e sua sintaxe é =PROCURAR(texto_procurado;no_texto_original)

ESQUERDA – extrai a partir da esquerda (início) uma sequência de caracteres até a posição especificada, e sua sintaxe é =ESQUERDA(texto;número_caracteres)

SEERRO – caso não consiga resolver a proposição, retornar uma mensagem/valor padrão, e sua sintaxe é =SEERRO(valor;valor_se_erro)

Esta ‘necessidade’ me lembra dos primórdios de minha atuação na informática, quando era programador de banco de dados dBase/Clipper, e usávamos funções TRIM e RTRIM para retirar partes dos nomes dos clientes, criando malas diretas ‘na unha’. Há 25 anos atrás… Estou ficando velho. 

Temos função dentro de função, assim, devemos resolver de dentro para fora.

– o que separa o primeiro nome do segundo nome na célula A2, onde está o nome completo “Luiz Cosmo da Silva Júnior” ? É um espaço em branco. Não é traço… Portanto, não poderia ser a letra A.

– como a gente localiza o primeiro espaço em branco dentro de um texto como “Luiz Cosmo da Silva Júnior” ? Se fizermos da esquerda para a direita, encontramos o primeiro espaço em branco. Se fosse da direita para a esquerda, encontraríamos o último espaço em branco. O enunciado diz que é Excel em português, portanto não pode ser a letra D, que usa o comando LEFT, esquerda em inglês. E novamente, não é a letra A, porque DIREITA iria procurar do final para o começo.

Poderia ser a letra B, C ou E como resposta.

– Poderia ser a letra B, porque está ‘bonitinha’, mas nem sempre no concurso a primeira resposta é a resposta correta. As funções possuem argumentos, e estes são separados por ponto-e-vírgula. A letra B está separada com vírgula, então está errada.

Restaram apenas as letras C e E. Elas são muito parecidas, e o que diferencia é o resultado. Portanto, estão construídas corretamente, mas a lógica está errada.

c) =SEERRO(ESQUERDA(A2;PROCURAR(” “;A2)-1);A2)

e) =SEERRO(ESQUERDA(A2;PROCURAR(” “;A2)+1);A2)

Resolvendo, de dentro para fora.

c) PROCURAR(” “;A2)-1) – vai procurar um espaço em branco dentro de A2, e retorna a posição encontrada menos 1. Para o texto em A2 “Luiz Cosmo da Silva Júnior” a resposta é 4, porque o espaço em branco está na posição 5.

e) PROCURAR(” “;A2)+1) – vai procurar um espaço em branco dentro de A2, e retorna a posição encontrada mais 1. Para o texto em A2 “Luiz Cosmo da Silva Júnior” a resposta é 6, porque o espaço em branco está na posição 5.

Agora estamos assim:

c) =SEERRO(ESQUERDA(A2;4);A2)

e) =SEERRO(ESQUERDA(A2;6);A2)

Para a letra C em ESQUERDA(A2;4) vamos retirar 4 caracteres de A2, iniciando pela esquerda. No texto “Luiz Cosmo da Silva Júnior” será ‘Luiz’.

Para a letra E em ESQUERDA(A2;6) vamos retirar 6 caracteres de A2, iniciando pela esquerda. No texto “Luiz Cosmo da Silva Júnior” será ‘Luiz C’.

Aqui já percebemos que a letra E está errada, porque retorna além do primeiro nome, do nome completo da pessoa.

A resposta é a letra C.

E a função SEERRO ??? Podemos dizer que a FCC colocou para complicar, para assustar o candidato, para distrair, enfim, sabe lá o que o avaliador pensou, né? Mas tem um motivo, um motivo prático.

Quando arrastarmos a fórmula da letra C para as posições abaixo, ela será copiada e colada. E atualizada. Ao chegar na linha 9, será A9, e não temos nada em A9. E como não temos valor, iria aparecer #VALOR! (erro de valor na planilha). A função SEERRO é usada para fazer o tratamento de erros. É para evitar que mensagens de erro (iniciadas com # ) apareçam na planilha. Há 25 anos atrás a gente já fazia isto, evitando que um erro fosse mostrado ao usuário, trocando ela por uma mensagem de erro, muito mais amigável. Ou seja, a letra C poderia ser apenas =ESQUERDA(A2;PROCURAR(” “;A2)-1), só que iria mostra #VALOR! caso não existisse um nome na célula da coluna A.

Então… Se não houver um valor em A2, mostre A2. Mostrará zero na célula. Foi por isto que foi usado o SEERRO.

Anúncios

Um comentário em “Prova: FCC – 2014 – TRT – 16ª REGIÃO (MA) – Analista Judiciário – Contabilidade

Deixe um comentário

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s